Excited to share my latest article on Medium: “Level Up Your Defender for Endpoint Deployment with Custom Compliance”!
paul-82465.medium.com/level-up-you...
#Defender #MDE #DefenderForEndpoint #M365Security #DefenderXDR
Latest posts tagged with #DefenderForEndpoint on Bluesky
Excited to share my latest article on Medium: “Level Up Your Defender for Endpoint Deployment with Custom Compliance”!
paul-82465.medium.com/level-up-you...
#Defender #MDE #DefenderForEndpoint #M365Security #DefenderXDR
New #DefenderforEndpoint updates: faster onboarding for Windows/Linux, custom telemetry, and new predictive shielding actions to harden exposed endpoints.
Stay ahead → learn.microsoft.com/en-us/defend...
[New Blogpost] - Modern Security for Legacy Systems
- Defender for Endpoint on Windows 7
medium.com/@verboonalex...
#DefenderXDR #DefenderforEndpoint #Windows7
From onboarding failures to passive mode conflicts and network blocks, our latest guide breaks down the most common causes (and how to fix them) so you can restore full protection fast.
levacloud.com/2025/10/29/d...
#MicrosoftDefender #EndpointSecurity #DefenderForEndpoint #MDESecurity #Levacloud
New blog post: Getting started with the Microsoft Defender Browser Protection extension for Google Chrome
petervanderwoude.nl/post/getting...
#MSIntune #Intune #EMS #MDM #Windows10 #Windows11 #GoogleChrome #MDE #DefenderForEndpoint #SmartScreen
Use #KQL to identify the use of Portable Apps across your #DefenderforEndpoint devices
github.com/alexverboon/...
Having worked extensively with Attack Surface Reduction (ASR) Rules recently, I thought it would be good to share some knowledge in relation to ASR alerting (or in some cases the lack of).
paul-82465.medium.com/asr-rule-ale...
#DefenderforEndpoint #ASR #MDE #AttackSurfaceReduction
Identifying vulnerabilities is just the first step—how you assess, prioritize, and remediate them defines your security posture.
Read more: levacloud.com/2025/02/26/v...
#CyberSecurity #MicrosoftSecurity #VulnerabilityAssessmentProcess #DefenderForEndpoint #DefenderForCloud #Intune #RiskManagement
@levacloud.bsky.social Tamper Protection in Microsoft Defender for Endpoint - Learn how to configure and enforce it in our newest blog post to prevent attackers from disabling security settings.
levacloud.com/2025/02/25/t...
#DefenderForEndpoint #TamperProtection #Levacloud #MicrosoftSecurity
[Tip!] Still running MMA for Defender for Endpoint on older Windows Servers/Clients? Not sure? Then check out these queries:
github.com/alexverboon/...
#DefenderForEndpoint #Security #StayCurrent
Microsoft 365 Defender for Endpoint - Microsoft Graph and PowerShell - List alerts for advanced hunting!
@microsoft.com @microsoft365.bsky.social @github.com @mvpaward.bsky.social #Microsoft #MicrosoftGraph #PowerShell #mvpbuzz #Security #coolstuff #DefenderForEndpoint
👇👇👇
github.com/tomwechsler/...
In my latest blog post, I wanted to talk about the nuances most organizations overlook with #defenderforendpoint device isolation and containment, and how these capabilities can co-exist next to containment actions via networking equipment.
hybridbrothers.com/device-isola...
#Microsoft
Microsoft 365 Defender for Endpoint - Advanced hunting on suspicion with Kusto Query Language!
@microsoft.com @msftsecurity.bsky.social @github.com @microsoft365.bsky.social #Microsoft #KustoQueryLanguage #EMS #mvpbuzz #Security #coolstuff #DefenderForEndpoint
👇👇👇👇
github.com/tomwechsler/...
🚀 Need to control USB device access in your organization? Here is how I created a policy using Intune! Learn how to block unauthorized USBs and ensure data security. Watch now! 📺🔒 #CyberSecurity #Intune #DefenderForEndpoint youtu.be/TpPPjQfBzCI
✨ #blog An excellent feature to close the gap when endpoints aren’t registering with Entra and not enrolling in Intune as expected.
#MicrosoftEntra #DefenderXDR #DefenderforEndpoint #EndpointSecurity #MicrosoftIntune
wp.me/pb2Sd0-2rZ
Would love if we could have the domain categorization info as part of the Domain page in the Defender portal instead of having to go digging in the web protection reports
#DefenderforEndpoint
Looking for a contact within Microsoft who can tell me more about this : . It's in beta and a customer wants to know when this is out of beta. #security #defenderforendpoint #defender
docs.microsoft.com/en-us/microsof…
#DefenderForEndpoint
Having fun looking through ASR data 🧐
DeviceEvents
| where ActionType == "AsrOfficeMacroWin32ApiCallsAudited"
| where InitiatingProcessCommandLine contains 'Downloads'